Upgrading from the coda.pdb/name.pdb databases used in 5.2.0/5.2.2

The initial release using the pdbtools used gdbm as the underlying data store. However we were unable to reliably use the resulting databases across heterogeneous servers. So we decided to switch to libdb 1.85.

There is no script available to automatically upgrade your gdbm databases to libdb 1.85 format. If you still have existing users.coda/groups.coda, simply run pwdtopdbtool.py.

Otherwise, you must extract all information using the old pdbtool before upgrading your SCM.

# echo list | pdbtool > full_pdb_dump

However, it is not possible to easily use this dump to recreate the database. Everything needs to be re-added to the new pdb database by hand.